Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

97-0-несколько условий Excel лого

Функция ЕСЛИ в Excel позволяет оценивать ситуацию с двух точек зрения, например, значение больше 0 или меньше, и в зависимости от ответа на этот вопрос, произведи дальнейшие расчеты по той или иной формуле. Однако, не редки ситуации, когда вам приходится работать более, чем с двумя условиями. В сегодняшней статье мы рассмотрим примеры создания формул в Excel с несколькими условиями ЕСЛИ.

Прежде, чем начать изучать данный урок, рекомендую прочитать статью про функцию ЕСЛИ, где описаны основные приемы работы.

Принцип создания формул с несколькими условиями ЕСЛИ заключается в том, что в одном из аргументов формулы (значение_если_ИСТИНА или значение_если_ЛОЖЬ) находится еще одна формула ЕСЛИ.

Например: =ЕСЛИ(A5=0;»НОЛЬ»;ЕСЛИ(A5<0;»МЕНЬШЕ НОЛЯ»;»БОЛЬШЕ НОЛЯ»)), где функция оценивает значение ячейки A5 два раза, первый, проверяет, равняется ли значение нулю, и возвращает текст – НОЛЬ, если ИСТИНА. Если результат оценки вернул значение ЛОЖЬ, происходит вторая оценка, функция проверяет, является ли значение ячейки A5 меньше ноля, и возвращает текст МЕНЬШЕ НОЛЯ, если результат ИСТИНА, в противном случае возвращает текст БОЛЬШЕ НОЛЯ.

97-1-несолько условий Если в Excel

Таким образом, в примере выше, формула вернет значение МЕНЬШЕ НОЛЯ, так как при первой оценке, результат оказался ЛОЖЬ, а при второй оценке ИСТИНА.

Давайте рассмотрим пример посложнее. Предположим, вам необходимо рассчитать размер комиссии каждого продавца в зависимости от объема его продаж.

97-2-несолько условий Если в Excel пример 2

Ваш план таков:

  • Если продажи меньше или равны 500$, комиссия составляет 7%
  • Если продажи больше 500$, но меньше или равны 750%, комиссия составляет 10%
  • Если продажи больше 750$, но меньше или равны 1000%, комиссия составляет 12,5%
  • Если продажи больше 1000$, комиссия составляет 16%

Вместо того, чтобы рассчитывать размер комиссии для каждого работника, можно создать формулу с несколькими условиями ЕСЛИ. Логика формулы будет следующая:

  • Продажи меньше или равны 500$. Если ИСТИНА, рассчитываем комиссию.
  • Если ЛОЖЬ, то продажи меньше или равны 750$. Если ИСТИНА, рассчитываем комиссию.
  • Если ЛОЖЬ, то продажи меньше или равны 1000$. Если ИСТИНА, рассчитываем комиссию.
  • Если ЛОЖЬ, рассчитываем комиссию, так как это будет означать, что продажи больше 1000$ и больше логических тестов проводить не нужно.

Давайте создадим формулу следуя данной логике для продавца Сергея. (Я выделил жирным проверку логики для лучшего понимания).

=ЕСЛИ(B4<400;B47%;ЕСЛИ(B4<750;B410%;ЕСЛИ(B4<1000;B412.5%;B416%)))

На первый взгляд может показаться, что это ужасная формула, но давайте попробуем разобраться:

Логическое выражение в первой формуле ЕСЛИ проверяет, является ли значение в ячейке B4 меньше 400, если ИСТИНА, формула умножает значение ячейки B4 на 7% и останавливает дальнейшие вычисления. Если значение ячейки B4 больше 400, мы переходим к следующей функции ЕСЛИ. Так будет продолжаться, пока мы не достигнем последнего значения, где значение ячейки умножается на 16%. Это значит, что ни одно из условий не удовлетворило требованиям, т.е. продажи составляют более 1000$.

Ниже вы видите, как будет выглядеть колонка Комиссия, когда все формулы будут введены. Также в колонке Формула отображены формулы для каждого продавца.

97-3-несколько условий если excel формула

Можно проверить на примере Натальи правильность работы формулы. Продажи Натальи составили 844$, т.е. больше, чем 750$, но меньше чем 1000$. Соответственно, коэффициент комиссии будет равняться 12,5%, а сама комиссия составит 105,5$. Также важно отметить, о работе формулы с пограничными значениями. Предположим, что сумма продаж Натальи составила 750$, какой коэффициент должна применить формула? Коэффициент будет 12,5%, так как для коэффициента 10% сумма продаж должна равняться меньше 750. Это важное замечание, поэтому будьте аккуратны при составлении логики формулы.

Итак, как вы увидели, формула ЕСЛИ очень мощный инструмент при составлении логических выражений с несколькими условиями и позволяет экономить время на просчет каждой ячейки таблицы.


Источник: http://exceltip.ru/несколько-условий-если-в-excel/


Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel

Как сделать двойное если excel